广州微信h5定制开发,h5创意互动小游戏开发,小程序开发设计制作,企业公众号html5外包定制_佛山惠州东莞最好小程序开发企业

谷歌 Play商店App的API等级需达28以上 编辑:www.gzyunna.com   时间:2019-03-26   点击:  栏目:资讯中心

谷歌也开始要求其他应用程式商店内应用程式的API等级,第一波先从中国开始,2019年8月中国应用程式商店新的Android应用程式,都需要达API等级26。



谷歌提醒开发者,谷歌 Play中的应用程式,在2019年11月前需要更新到API等级28(Android 9)以上,而HUAWEI、OPPO、Vivo、小米以及百度等中国应用程式商店,开发者也需要更新应用程式达API等级26(Android 8.0)或更高等级,否则在2019年11月后,使用者将在安装应用程式时收到警告。

在2018年11月后,谷歌 Play上的应用程式都已经达API等级26或以上版本,除了应用程式得以获得更新的API功能支援外,也能改善隐私以及安全性,让使用者能精确的控制共享的资料,而现在谷歌要继续推进应用程式使用API??的版本,释出2019年Android的API更新计画。

谷歌 Play主控台将会在2019年持续检查应用程式的API等级,谷歌提到,在2019年8月后,所有新上架的应用程式,都需要使用高于API等级28的API,而在2019年11月后,所有现存的应用程式更新,也必须达API等级28以上。而没有更新的应用程式则不受影响,使用者可以继续从谷歌 Play中下载,而开发者也仍然可以使用minSdkVersion,继续为较旧的Android版本建置应用程式。

另外,谷歌还进一步规范透过其他线上商店发布的应用程式,首先要求HUAWEI、OPPO、Vivo、小米、百度、alibaba和Tencent中国应用程式商店,其提供的应用程式皆达API等级26以上的要求。谷歌指出,他们在谷歌 Play之外侦测到有95%的间谍软体,皆故意瞄准API等级22或是更低的版本,因此即便这些应用程式在最新的Android作业系统中实行,也能避开权限限制。

为了保护使用者免受恶意软体攻击,并促进生态系的发展,谷歌 Play Protect将会开始在系统安装未达到特定API等级的APK时,对使用者发出警告,第一个时间点将在2019年8月,当新的应用程式使用未达API等级26以上版本时,使用者将在安装期间收到警告,而第二个时间点在2019年11月,当现有应用程式的新版本未使用API??等级26以上版本时,则使用者也会在安装期间收到警告。

谷歌提到,只有当应用程式的targetSdkVersion低于装置的API等级时,谷歌 Play Protect才会发出警告,例如使用者Android 6.0装置,安装使用API??等级25以下的APK就会获得警告。另外,在2019年8月前,谷歌就会为开发者装置启用警告,以提前通知开发者进行更新准备,但同样的,没有更新的应用程式将不会受到限制。从2020年开始,谷歌会每年推进API等级要求。


本文由澳门新萄京娱乐场发布,转载需要注明:编辑www.gzyunna.com

?
XML 地图 | Sitemap 地图